Jump to content

Dear Visitors

If your confirmation email doesn't arrive, give us some time while we manually approve your account. Support ticket is not necessary, we are checking new registrations regularly and approving if registration requirements are met.

Please read Rules & Guidelines before posting around Forums. Information we seek is minimal and in the end saves us a lot of time and we are able to provide solutions faster.

Please consider supporting us via Contributions for all the work we are doing. Contributing even with the smallest amount, will remove ALL AD's and unlock some nice features like being able to be Tipped for providing help, or file etc.


Camera Scale doesn't render


Go to solution Solved by Cerbera,

Recommended Posts

Hi, I'm new to Cinema and I have this problem, where I used the camera scaling (under coordinates) to change the scaling of the camera slightly to adjust the perspective to better fit the original (its a uni project). The problem is, the scaling works fine on the preview window, but when i render it, the scaling disappears (and i created a copy of the original cam without the scaling to check if that really is the source of the problem).

As You can see in the attached images, the preview fits the original pretty well, while the render is slightly smaller and thicker.

I checked about every box on the camera settings, triple checked if i used the right camera and tried finding a solution online, but without success. Any help would be highly appreciated!

Bildschirmfoto 2021-08-31 um 17.28.29.png

Bildschirmfoto 2021-08-31 um 17.27.42.png

Bildschirmfoto 2021-08-31 um 17.27.30.png

Link to comment
  • Solution

No, it sounds like you're basically doing that wrong, but hard to confirm exactly what the issue is until you upload the scene file.

 

My own expertise is more in modelling, but generally speaking, as I understand it, the camera scaling should remain at 1,1,1 and you should change your render output settings to match the perspective / dimensions you want in your final image, then frame the scene using the camera lens controls in the object tab to set aspect ratio / focal length / sensor size etc. 

 

Use the Safe Frames feature to see in viewport what area will be rendered. Also make sure you are actually rendering through the correct camera !

 

CBR

Link to comment

Thank you for your reply! 

I figured that I was doing it wrong. Though it generates the question why there even is the option to change the scale, if it doesn’t output in the render and never should be used anyways.
 

I already checked if i was using the correct camera multiple times though, so I'm pretty sure on that one at least.

also, here is the link for the dropbox, i thought that maybe it wasn't needed
https://www.dropbox.com/s/3n1g97zovwn7eir/1.7b_SWFC_Texturieren.c4d?dl=0

Link to comment

Not 100% on this, but I believe the scaling option is there to match the camera icon size in the viewport with the geometry scale (Object Mode), so we can avoid situations where the camera is radically larger or smaller than the scene scale. Otherwise it's probably there for object / interface consistency ! (Edit: Oh - I see srek beat me to it 🙂

 

I agree you are rendering through the right camera, and that you are correct that PV rendering ignores that scale value, so much better to do what I suggested initially I think, and control it another way...

 

CBR

 

Link to comment

Just another thing I notice - you seem to be getting somewhat horrible building textures in your render too - is the faceting and triangulation there notably absent from your VP preview intentional ? Cos it looks like it could be a load of ropey geometry and phong shading errors, and that should be fixable if we know what we're aiming for...

 

CBR

Link to comment

Do you mean the weird triangles that appear while rendering? If so, then no, those are not intentional, just a problem I haven't fixed yet. The farthest that I got in that regard is that if I turn off all lighting and just use GI, the triangles disappear, so I suspected some issue with the phong, but I don't have the slightest idea how to fix that

Link to comment

Thanks for the quick reply! 

I did copy the whole thing, but then deleted it because it caused other problems. But maybe some polygons remained, I will definitely check again! Is there a way to highlight coplanar surfaces, like some programs can highlight duplicate lines, or similar? Or should I just search by hand?

 

Edit: I checked if there were any duplicate surfaces but didn't find any, though the render still shows the weird triangular lines. I also tried untriangulating the surfaces, after converting the current state to an object, but without any success

 

Edit 2: for anyone in the future who may see this: The problem never was with the polygon, instead one of the lights had the shadow map (soft) activated. After changing it to Raytraced (Hard) or Area, it works!

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • LATEST ACTIVITIES

    1. 0

      Windows from polygons - example nodes

    2. 462

      Cinema R25 Release

    3. 3

      Angle difference between 2 matrices

    4. 462

      Cinema R25 Release

    5. 462

      Cinema R25 Release

×
×
  • Create New...

Copyright Core 4D © 2021 Powered by Invision Community