Jump to content

Dear Visitors

If your confirmation email doesn't arrive, give us some time while we manually approve your account. Support ticket is not necessary, we are checking new registrations regularly and approving if registration requirements are met.

Please read Rules & Guidelines before posting around Forums. Information we seek is minimal and in the end saves us a lot of time and we are able to provide solutions faster.

Please consider supporting us via Contributions for all the work we are doing. Contributing even with the smallest amount, will remove ALL AD's and unlock some nice features like being able to be Tipped for providing help, or file etc.


Arrowhead "Falls Behind" While Animating Along Spline (using Cloner)


srakar
Go to solution Solved by MJV,

Recommended Posts

So I have a scene where I'm trying to animate an arrowhead that moves along the course of a sine-wave shaped spline as it is formed. I'm using a formula object spline with a sweep to generate the line itself. And for the arrowhead I have a cloner with 1 clone (the arrowhead) that should be following the course of the spline. I'm keyframing the Tmin property of the formula function so that the line is generated over time. 

On certain still frames, this looks great. The arrowhead is at the end of the spline and pointed in the right direction. However, once I actually hit play on the animation, it seems like the arrowhead suddenly has trouble keeping up with the end of the spline. It keeps falling behind for some reason. It appears that randomly changing a number in the cloner's transform section and then changing it back will suddenly make the arrowhead jump back to its correct position. But then when going to render, it displays the wrong "falling behind" positioning instead. 

Alternatively, I've tried animating the arrowhead using the "align to spline" tag instead, but that option doesn't seem to properly display the rotation of the arrowhead (even with tangential turned on).

Does anyone have any ideas on how I could make this animate properly? Thanks!

Cloner-Arrow_Fall-Behind-Issue.jpg

Link to comment
  • Solution

Sounds like a priority issue of some sort.  I would try putting the Cloner object below the Sweep in the Object manager so that the sweep calculates first. If that doesn't work, then I would consider doing this another way such as animating the Sweep's End Growth parameter to reveal it and then use expresso to match the arrow to the End Growth point, which is how I do stuff like this. I do admire the uniqueness of your approach though which shows how there are so many countless ways of doing the same thing in Cinema. 

Link to comment

Whoa, you were absolutely right - switching the order of the cloner and the sweep immediately fixed the issue. Thank you so much! I had no idea the order of un-grouped objects in the object manager could have an effect like that. I very much agree that it's impressive how many ways there are to do things in C4D. It's always fun to see how different people will approach the same problem. I'll definitely give your method a try after I finish up this project. Thanks again for your help!

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • LATEST ACTIVITIES

    1. 0

      Windows from polygons - example nodes

    2. 462

      Cinema R25 Release

    3. 3

      Angle difference between 2 matrices

    4. 462

      Cinema R25 Release

    5. 462

      Cinema R25 Release

×
×
  • Create New...

Copyright Core 4D © 2021 Powered by Invision Community