Jump to content

Dear Visitors

If your confirmation email doesn't arrive, give us some time while we manually approve your account. Support ticket is not necessary, we are checking new registrations regularly and approving if registration requirements are met.

Please read Rules & Guidelines before posting around Forums. Information we seek is minimal and in the end saves us a lot of time and we are able to provide solutions faster.

Please consider supporting us via Contributions for all the work we are doing. Contributing even with the smallest amount, will remove ALL AD's and unlock some nice features like being able to be Tipped for providing help, or file etc.


Redshift 3.0.50 does not show up in C4D R23


ingvarai
Go to solution Solved by ingvarai,

Recommended Posts

Redshift 3.0.50 does not show up in C4D R23, not at all. The installer adds it to the plugins directory, so so far it should be ok.

It shows up, and works fine, in R18, R19, R20 and R21. But not in R 23.
I have the latest NVIDIA Studio drivers installed.

 

This happened when I upgraded Redshift to 3.0.50. It was fine before, I could use it in R23 as well.

Here is an update:
Version redshift_v3.0.41 works fine.
Versions above this will not show up in C4D R23. I have tested v3.0.42, v3.0.43, v3.0.45, v3.0.46 and v3.0.50
They do not show up in R23.
 

What can be the problem here?
-Ingvar

Link to comment

I solved this R23 problem by downloading C4D  R23.110 and installing it. I have no idea why I could not get this version by just invoking "Check for updates". Why is that?
OK, now I can install the latest Redshift versions for my R21 and R23.
However - a BIG however - the latest versions are not compatible with  my C4D versions R17, R18, R19 and R20.

redshift-install-041.png.b5cc9f90943d191d22d79ceb1c02fb98.png

 

When I install the latest versions:
redshift-install.jpg.221c5cbb73d39b0a1ff84945cc98b0a4.jpg

 

Redshift is removed from those older C4D  versions.
This is frustrating, because I have some plugins in the older versions, and sometimes I render out in the older versions too.
There is probably no way to keep Redshift for these versions?

-Ingvar
 

Link to comment

I think that was said few months back that RS will start support those version from now on. Which I can totally understand. There was simply to much changes at this point and support so much versions back is such a pain for dev team. 

 

8 minutes ago, ingvarai said:

I solved this R23 problem by downloading C4D  R23.110 and installing it. I have no idea why I could not get this version by just invoking "Check for updates". Why is that?

I am really not sure, it could be a bug, but its hard for me to say.

U-Render Quality Assurance Specialist | Follow Houdini PolyMarvels  YouTube | Twitter | Discord

Link to comment
  • Solution

Thanks a lot Igor, for your prompt response!
In the mean time, I have found out a couple of things, I hope this will help others to, who happen to read this post, so here it is:

When it come to Cinema 4D R23, from what I understand, version R23.110 has to be downloaded from Maxon, directly, and installed, by hand, by you, as a user. Furthermore, all those giant libraries and assets also have to be installed again, even if you most likely already have them on your machine. I have a super fast fiber Internet connection, so no big deal for me, But for others, it will take a lot of time.
I haven't gotten any mail or hint from Maxon, that there is an update for R23. Not good.

When it comes to Redshift, from my own investigations, redshift_v3.0.55 is the last one to support R18, R19 and R20.
But, as I also found out, it should be possible to keep redshift_v3.0.55 for these older C4D versions, and install the newer one for R21 and R23.
This can be achieved by downloading the zero install zip-package, and then run certain *.bat files (there is an instruction contained). This will allegedly install the latest version for R21 and R23, and keep the previous version for the older C4D installs. I haven't tried this yet, but Redshift claims it will.


-Ingvar
 

Link to comment
  • 2 weeks later...

Hi, the previous post is not the solution. I wrote allegedly, which was wise - because it doesn't work.
Here is how to do it:

 

Redshift versions and Cinema 4D support:
Last version for R16 is Redshift 3.0.27
Last version for R17 is Redshift 3.0.43
Last version for R18, R19 and R20 is Redshift 3.0.55


This procedure assumes that you already have Redshift installed, and licensed.


Step 1:
Under C:\ProgramData\Redshift find, and copy these two files to a safe place:
redshift-core.lic and redshift-core2.lic


Step 2:
Install Redshift for one of your now unsupported Cinema 4D versions. I started with the lowest number, and worked my way up.
Run the installer, in this case redshift_v3.0.27_setup.exe
If not present, copy the above mentioned *.lic files to C:\ProgramData\Redshift


Step 3:
Rename the directory C:\ProgramData\Redshift to something suitable, I renamed it to C:\ProgramData\Redshift_v3.0.27


Step 4:
Open the Redshift directory for the Cinema 4D version in question, in my case
C:\Program Files\MAXON\CINEMA 4D R16\plugins\Redshift

In this directory you shall create (or edit if existing) a file with the name pathconfig.xml
Enter these two lines:

 

<path name="REDSHIFT_COREDATAPATH" value="C:\ProgramData\Redshift_v3.0.27" />
<path name="REDSHIFT_LOCALDATAPATH" value="C:\ProgramData\Redshift_v3.0.27" />

Save the file.


Step 5:
Repeat this for your C4D versions and the corresponding Redshift versions. With one exception, there is no need to rename the C:\ProgramData\Redshift directory for the latest currently supported Redshift version.

That's it. I hope this will help someone! I struggled a bit with this, but now I can render out with Redshift from Cinema 4D R16 and up till today's version.


This is how the Program data directories now look on my PC:
redshift-programdata.jpg.2b1177256784c2d7b27ad562a25dff02.jpg

-Ingvar

 

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Copyright Core 4D © 2021 Powered by Invision Community